Wikia

Elder Scrolls

Talk:Geirmund's Hall

27,476pages on
this wiki

Back to page

can not find the fragment, I see the location but can get to it. how do I get it?

18:07, October 28, 2012 (UTC)18:07, October 28, 2012 (UTC)~~unsigned noob questions

im stuck... trying to get the bridge to lower but it just sends out spikes... is there some puzzle I should've seen and solved?

solution: theres a lever on the wall on the opposite side.

EtA: Uhhhh.... problem is, how do I get to the opposite side? I think I might have taken a wrong turn somewhere... I was supposed to go down the hole in the floor in the beginning, right?

Yes, you go down the hole.


i cannot solve the puzzle in Geirmunds Hall... the first one, i see the correct tabs but it witch order they go i dont know

Try looking on the page itself, it has the proper order. More eficient than the talk page at the very least. ~MP

Wheres the damn exit Edit

I cant get out of this place. when i came in, there's a big hole you drop down into the water and no way to get back up. i've looked around every inch of the place and there's no other exit. Doesn't help that the in game map overlaps places


From a highly exalted adventurer. I will tell you the run down of Geirmund's Hall.

One: Enter cave from island near Ivarstead.

.5: Jump in hole into water.

Two: Walk up wooden ramp.

Straigtforward until the bridge.

Halfway their is a puzzle where you are partially in the water, if I remember correctly. The answer is nearby, that's all I can give you, it is either in the room with the columns or very close. (The answer is before the pillars. ~MP)

next up is the bridge.

There is that lever that causes spikes. Walk up to it, and look directly behind you. There should be another lever on the wall right there, kinda hiding.

Hit it, it drops a bridge. Next lever is on the left side of round circlet on pillar. Hit it.

Next bridge drops.

Straightforward until exit.

Fight Sigdis Gauldurson, he mainly use the disarm shout. He teleports, and creates copies of himself. The copies have no horns on their helms, but Sigdis does, so you can tell them apart. It's a good idea to rush up and try to kill him as he is rising from his sarcouphagus, before he teleports.

After defeating Sigdis follow the path up and after a good way, maybe even another chamber, there should be a dead end at the end of a winding natural rock tunnel.

Their is a lever near it. Hit it, Viola, EXIT.

Where and how do you get down to the Gauldur Amulet Fragment? in this place.

The fragment should be on the defeated drauger. (Unless there was premature exploration, I believe.) ~MP

hidden underground chamber?Edit

The article says: "To access the hidden underwater chamber you must open the door by activating the Raised Stone underwater, immediately below the hole you just jumped down." I see no Raised Stone anywhere near that place, or elsehwere in the dungeon. --Piotrus (talk) 00:20, December 16, 2011 (UTC)

It's literally underneath the hole you jump down, next to a submerged urn, but it doesn't stand out - just swim beneath the hole, look straight down and the activation hint should appear. The grey rock is on the floor. You may hear it clanking while you move around it.

Loading Issues Edit

Every time I try to enter the cave entrance, the game tries to load it, but I just get stuck on the loading screen with the swirling fog. I'm on Xbox. Can anyone help me out with this? (69.76.18.125 10:26, February 1, 2012 (UTC))

I had the same error on the PS3, I eventually just let it sit for a long time and it eventually loaded.

Possible Bug Edit

I found a new bug when fighting the boss. I am a high level and was using a legendary daedric battleaxe. When he got out of the coffin i power attacked him and then critical attacked him, so he died almost instantly. The quest marker was visible but his body was invisible/ was not there at all because it couldnt be searched. I couldnt get the Amulet so I had to load a previous save.

Edit: After doing the boss fight a second time, I must have critical hit him while he was doing his first teleport, making his body not exist

Missing key bug Edit

Sometimes the key wont appear in Geirmund's hand or next to his body, reloading a save usually fixes this. I noticed this bug is not listed anywhere on this page or the forbidden legend page. Khaotix523 (talk) 00:31, January 23, 2013 (UTC)

Around Wikia's network

Random Wiki