Wikia

Elder Scrolls

Talk:Hjerim

26,391pages on
this wiki

Back to page

Where do you purchase the house? o.Ô

I think you need to complete the quest, Blood on the Ice first. Then the Jarl's steward probably offers it. Not sure though. I bought a different house. It seems kind of silly to have a catalog of images showcasing the house, without telling how to buy it. --— Radical D (bother \ stalk) 13:23, November 18, 2011 (UTC)

Can't buy it Edit

I've finished the Blood on the Ice quest, but I was never offered the chance to buy the house. I have never been asked to do a personal task for Ulfric, nor have I been named Thane of Windhelm.

I simply completed the quest and then the steward (his name escapes me at the moment) mentioned that the guards may look upon me more favorably now. But nothing about becoming a Thane and nothing about buying the house.

I really, really, really want to get a house in Windhelm, because my character just took the decision to move from Whiterun following.. "developments". luckmanngrenadesignatur.png Luckmann 23:57, November 18, 2011 (UTC)

I bought the house after completing the task he gave me, where he asks med to find the Helm of the Jarl. Look under Miscellaneous and see if you have gotten it, without noticing it. I didn't complete Blood on the Ice before buying the house, so this is not requried, but it might be a bug that you can't get the quest from the Jarl. But you must complete his personal task before buying Hjerim, although I don't know if there are any quests before the Jarl's task. /Drizer
I have never been offered a personal task of any kind by Ulfric. :( luckmanngrenadesignatur.png Luckmann 23:57, November 18, 2011 (UTC)
Well I can say for certain that I have not received a quest to find a helmet for Ulfric. The only quest to find a helmet that I've got, was to find the Helm of Winterhold for the Jarl of Winterhold. Maybe it is bugged, because I joined the Stormcloaks and completed Blood on the Ice before doing it? After voicing a desire to join the Stormcloaks, Ulfric directed me to Galmar Stone-Fist and did not speak to me anymore, until the next part of the Stormcloak questline.

Where was the Helm of Windhelm? Maybe I can do what I did for Winterhold? In Winterhold, I accidentally found the Helm of Winterhold in a dungeon, picked it up, and received a quest to deliver it to Jarl Korir, the Jarl of Winterhold? So if I can find the Helm of Windhelm, maybe I'll automatically get the quest to deliver it to Jarl Ulfric, thus bypassing whatever broken piece of dialogue that is preventing me from getting it now? luckmanngrenadesignatur.png Luckmann 07:50, November 19, 2011 (UTC)
I am guessing that the "helm" in question is the The Jagged Crown, part of the civil war questline. From what I can tell (and this has taken a hell of a lot of research and may be completely wrong), you need to "deal with" Whiterun and then retrieve the Jagged Crown before you are offered the house for sale. For players like myself who want to avoid the civil war quest line for whatever reason, it looks like there's no way to get this house. If anyone can confirm or debunk this, I'd appreciate it! Feralkyn (talk) 04:39, November 24, 2011 (UTC)
Okay, so many things are involved with getting this house people become confused. First off, you have to choose a side to get this house. If you go storm cloaks, Ulfric will not offer to let you buy land in Windhelm until after the third quest in the civil war line. If you go Imperial, you will not be able to buy the house until Ulfric's replacement gives you a quest to find the Helm of Windhelm. But that is just to be allowed to buy a house. You must complete Blood on the Ice for Hjerim to even be up for sale. I've heard this works differently on xbox, but I have PC so...
Well the real problem is getting the quest started. Chris-the-killer 01:36, November 27, 2011 (UTC)
In most other cities you have to buy a house and help the people before becoming a thane.
I noticed that I became a thane after completing the Stormcloak quests and after helping
the 5 people but before buying the house. So, now when I try to buy the house I get the
same message as everyone else about it not being ready. Also I am a dark elf and I don't
know if that might have some bearing on it given the segregation. 98.240.34.232 01:40, November 28, 2011 (UTC)TimHasAnAfro


Upon speaking with the Jarl, he will tell you, that you need to be known amount the people of Winterhold. If you completed 5 quests and finished the 'Blood and Ice' quest you can buy the house. However, a lot of bugs are known regarding this issue. Most of them have to do with a certain contract from the 'Dark Brotherhood'. You get the quest to kill a woman in the 'Hall of the dead', after this is completed her mother commits suicide and because of this bugging the quest and the purchase of the house. Nothing is known on how to fix this. However you are able to buy the house anyways: (PC only)
1. open console
2. type "setstage a7b33 10"
(if the quest 'Blood and Ice' is bugged)
3. "completequest ms11"
4. "completequest ms11b"


I became Thane of Eastmarch, i completed the civil war questline as a Stormcloak, i purchased Hjerim, the Steward gave me the key, i entered the house and it started the 'Blood and Ice' quest, the quest doesn't allow me to talk to Viola, and I can't buy any decorations for Hjerim, any suggestions? I play on PS3 if that helps..

Buy the house without starting the related quest. Edit

How do you buy the house without starting the quest? Whenever I go up to the Jarl's stewart it gives me the option to buy but he won't sell it to me due to recent "unpleasentries." So is there a way to get into the house without buying it or without having to start the quest? Chris-the-killer 19:18, November 26, 2011 (UTC)

I got in by pickpocketing the key to the lock from the Shatter-Shield mother and got in Hjerim, however the quest did not start even after I read Both of the Butchers diaries and clicked on some investigation things Chris-the-killer 20:12, November 26, 2011 (UTC)

ImageEdit

This article needs an image of the house's exterior for the infobox. --— Radical D (bother \ stalk) 19:35, November 26, 2011 (UTC)

Help for buying this house. Edit

Civil WarEdit

How long does it usually take for the replacement to show up after you have killed Ulfric? It has been 4 in-game days since I have killed him yet the replacement has not shown up yet and the bodies of Ulfric and his bodyguard are still lying there next to the throne. Skål! (talk) 01:52, December 2, 2011 (UTC)

I'm having the same problem. Brunwulf's just cruising the city; nothing indicates he's jarl, and Jorleif's still in his Steward spot, not selliing me the house. Galmar and Ulfric are still lying next to the throne. Maybe if I drage them away it'll work...84.58.210.106 12:48, April 7, 2012 (UTC)Tim Bostick

ShelvesEdit

The mentioned shelves aren't bookshelves, just regular shelves. --84.151.141.192 23:01, December 8, 2011 (UTC)

Secret RoomEdit

The secret room does not disappear after the cleanup of the murder scene is ordered. Instead, the altar, the boddily remains and the blood are cleaned up, and the room becomes your house shop, or "mancave", if you will. An Arcane Enchanter is placed in there, as well as an Alchemy Table, along with two shelves. One is stocked fully with several different Soul Gems (including Black and Grand ones) while the other is stocked with several different alchemy ingredients. The Secret room also retains it's mysterious wardrobe with hidden sliding door entrance, preserving the sweet "mancave" properties one could expect the Dovahkiin would have in his very own mansion.

Missing Chest Edit

After purchasing Hjerim and all of the rooms, the chest at the end of the bed was gone. This is actually my third playthrough of the entire game, and this is the first time the chest has failed to show up. I haven't done anything differently than my last two playthroughs, so I really don't know why it's not appearing. I do know the code for the chest, and I've tried to "enable" it through console commands, but everything I've tried doesn't work. The code for the chest is 000df5ac. The game aknowledges that the chest exists, and when I "moveto" it, I warp to the foot of the bed, but again, the chest is invisible. (99.136.224.214 02:12, December 30, 2011 (UTC))

I can't get any of the display cases or weapon racks to work, is there a fix for this ?82.21.241.39 13:10, January 15, 2012 (UTC)

Regarding: the newest patch (XBOX360) Edit

So, um the new patch came out, so what's the deal with buying the house, is it working properly or still broken?

Does anyone have any news on the updates? Has anyone had any luck buying the house without the various "breaks" in the Blood on the Ice quest?


"Those who hammer their guns into plows will plow for those who do not..." Thomas Jefferson. Helena 19:16, February 10, 2012 (UTC)HelenaHanbazkt


Yeah, I purchased it, and actually everything in the house seems to be working now (for me, anyway)

I also purchased everything for the house (including cleanup and House Carl's quarters) at once, before entering. Hope it helps! MHarris7 (talk) 20:44, April 12, 2012 (UTC)

Used Free House Exploit With a corpse!Edit

Hehe... You Know that Exploit that gives you a free house? Well I know how to use it at daytime near in the throne room in the palace of kings. Complete the Civil War In imperial favor. if Ulfric Stormcloaks Corpse does not disappear you can use it as a legal container for gold. Drag his body to the throne where Jorleif stands. buy Hjerim and exit the conversation and stuff ALL your gold in his body. The exploit shall take effect. Since the furnishing is pretty expensive as well, I suggest you just use the exploit with it as well. This works and is pretty funny considering I used the corpse of the ex Jarl!!!


Please sign your posts. SpectreAngel (talk) 02:07, June 28, 2012 (UTC)


Was about to point this out as well, look like I was beaten to it by months... Confirmed with latest Ps3 patch as of this date. (Corpse Storage/No Payment for Purchase and Decoration) And also, you do not NEED Ulfric's corpse in particular, my Dead Thrall works/ed fine. Yumeyo-yuki (talk) 20:53, December 18, 2012 (UTC)

Possible fix to the bedroom chest not showing up Edit

I may have figured out how to avoid the bug where the chest in the master bedroom doesn't show up. From my experience, YOU HAVE TO GO TO JORLEIF AND BLAME WUUNFERTH THE UNLIVING for the murders during the quest, not to confront him directly about it. Then you can continue the quest normally after a few days, and the chest appears in Hjerim after you buy the house. I tried this three times just to be sure, but I would still like someone to confirm this. I'm also playing on PS3.

SuperHusky (talk) 17:34, April 15, 2012 (UTC)

Calixto Respawns?Edit

So I completed Blood on Ice a long time ago (about ~150 play hours ago) and only bought the house today. As soon as I walked in the house my follower (cicero)


Anyone else had him respawn?--{{SUBST::User:Riceygringo/sigtwopointoh/ref}} (talk) 04:05, August 15, 2012 (UTC)

Is his body supposed to be present still after I bought the clean up upgrade first then the enchanting one? He's still there. Wenny0119 (talk) 05:48, May 13, 2013 (UTC)

House Carl's Quarters? Edit

Hi all. Just curious on this... In Hjerim there is a smallish room upstairs that remains empty regardless of what decorations are purchased. Is that the house carl's quarters? I don't currently have a house carl in Windhelm and I didn't have the option to purchase the quarters for one. Otherwise, there just appears to be a random, useless room in the house lol

173.19.79.253 03:51, August 28, 2012 (UTC)

addendum, Sorry, I wasn't logged in when I posted this.

EarthBoundMisfit (talk) 03:52, August 28, 2012 (UTC)

The small room across from the master bedroom is indeed the house carl's quarters. Once you get the house carl it becomes fully furnished and not a useless room. Mntbrrychch (talk) 07:43, August 28, 2012 (UTC)

Wardrobe in MasterBedroom Edit

There is a mention on the main Hjerim page under the decorating options. It says That it is not recommended that you store anything in the wardrobe in the master bedroom as it could disappear and all of the items would be lost... I don't see a bug listing or any other information on what's going on with that particular wardrobe, and why it can't be used/why it disappears, etc.

EarthBoundMisfit (talk) 04:00, August 28, 2012 (UTC)

Expanded Edit

Possible bug with larceny targets and others as decorationsEdit

After selling all larceny targets to Delvin Mallory, I decided to take them off the shelf and use them as decoration in the Hjerim. With the Honningbrew Decanter placed somewhere, itself and numerous other objects have clipping issues. The Decanter always seems to clip, whereas the Bust of the Gray Fox, the Left Eye of the Falmer, the Model Ship, the Map of Dragon Burials, and the Oghma Infinium. Tested on  PS3   with no DLCs and the latest update. Has this happened to anyone else? Nuadha (talk) 17:03, March 18, 2013 (UTC)

Cant buy Edit

I finished the ciivil war as an impeirel and now i have the option to buy the house and im thane. But when i go to buy the house i cant because of unplestness, and i tried starting blood on the ice but it wont start so i did it myself but i cant talk to anyone and stll cant buy it, i play on 360 so anyone know how i can "fix" the unpleasentness and actully buy it?67.166.88.97 23:23, December 11, 2013 (UTC)xSTx

I bought the house and was able to get in perfectly, after I bought all of the upgrades however, whenever I enter my ps3 crashes.

Around Wikia's network

Random Wiki