Wikia

Elder Scrolls

Talk:Ironbind Barrow

28,243pages on
this wiki

Back to page

I confirmed this and there is an axe of firery soutrap hanging on the back of the throne in the room where you fight the Gathik


Glitch (Xbox 360): When I first got here, I was unable to find the Fiery Soultrap enchanted axe. After a bit I found it hovering above the pit in the middle of the air, out of reach of grabbing. A quick arrow shot brought the axe to the ground. Figured I'd add my two cents in case someone else has the same problem.


Glitch (Xbox 360): When I got to the end I could not learn the shout. I could hear the chanting and the "burning" sound effect but none of the words were lit up. I tried reloading and reentering the dungeon but nothing works. I couldn't find anything on this anywhere. Anybody else experience this?

I have the same problem (can't learn the shout) on Win7 Edit

A common problem, not just with this one but word walls in general sometimes do not work properly and you have to reload a previous save and start over again. sometime you have to load a save prior to your last autosave (a save outside of the area containing the word wall)

"Note you will only be able to access the throne room after the end of the quest through the Ironbind Barrow Overlook on the side of Mount Anthor."Edit

This needs clarification. Which quest, Location of quest, etc. Kyrailz (talk) 01:33, March 10, 2012 (UTC)

I found that this is not true. I went back after clearing Ironbind to see if I missed the axe. The gate to the main chamber was closed but I found I was able to open it by taking any object from my inventory and dropping it on the pedestal.

NPCs get left behindEdit

After killing the spiders I rushed ahead and opened the door before being told to do so. Those 2 idiots who were following me started looking for a way to open the door after that, and simply never stopped looking. So I just went through solo. Was a lot easier too (I already failed before), because I was a stealth character, and could just 1-shot everything but the boss (which I 3-shot, using an invisi-pot after the first 2 hits to avoid detection). After that I ran back, talked to the lizard guy, and he betrayed me anyways (well, he tried :P). 95.96.142.89 23:38, April 24, 2012 (UTC)

NPC missing upon entering the barrow Edit

I have a problem that, if I enter the barrow _after_ the NPCs, they will disappear when I entering the barrow. I tried several times and every NPC went _before_ me got disappeared. If I enter the barrow first, they will enter as normal.

Bug needs confirmation - Shout weirdness Edit

Can anyone else confirm this bug? Also, on what platform does this occur?

  • If you get to the Word Wall at the end of the dungeon, without doing the quest with Beem-Ja and Salma, you may not get the Become Ethereal shout, though it will be notified that you already learned it.

Cubears (talk) 03:34, May 28, 2014 (UTC)

Around Wikia's network

Random Wiki