Wikia

Elder Scrolls

Talk:Waking Nightmare

27,390pages on
this wiki

Back to page

On the bug with the follower, I accidentally entered the temple before Erandur got there and it said I couldn't enter here with a follower then left and both Erandur and my follower were standing outside then I talked to Erandur and went in with no problems. Came out with my original follower just waiting for me even though i hadn't told her to wait there. 69.151.72.76 07:38, November 29, 2011 (UTC)

Going nowhere fast Edit

How do you release the miasma? There seem to be no levers or buttons, and my magic has been nerfed. Wunengzi (talk) 13:06, January 11, 2012 (UTC)

By where the barrier is in the present, there should be a pull chain there from where you come from in the past. You walk for a really long time for such a simple, yet unopposed task.LeatherNeck2382 (talk) 18:18, January 11, 2012 (UTC)

Erandur tells me to follow, but he doesn't move. Edit

After going through the dialog to start the quest, he then tells me to follow him, but he just stands there. If I exit the inn, re-enter and talk to him, he points and tells me about the temple, then says lets keep going, but he just stands there. --jimnms (talk) 01:31, January 26, 2012 (UTC)


^^^^ Im having the same problem!!!!!  ^^^^^


^^^^^ hes stuck on the barstool right? give him a solid FOOOOSROOODAHHH to dislodge him, he will become hostile so sheath your weapons and he should become neutral allowing you to finnish the quest. it worked for me good luck


^^^^^^ if you have the shout "Ice Form" and stand on the bar and face Erandur and shout at him and make sure that you hit ONLY him, he will freeze and then unfreeze, get up and start walking to the door so you can continue the quest.

Skull of Curruption > (greater than) Having Erandur as a FollowerEdit

Ok, so i'm on my second playthrough and i decided to allow Erandur to destroy the Skull of Curruption this time (1st time around i killed him) and i'm like 5min into having him as a follower and it's clear as day that it is WAY cooler to have the staff then to have this guy alive!.. I plan on reloading my save file and killing him.

I want someone to disagree with me on this! Or.. agree with me... either way, i would like some feedback here with your take on it! DrunkenSushi (talk) 07:54, February 2, 2012 (UTC)

You should kill him if you want to earn the award for getting 15 Daedric artifacts.DarthOrc (talk) 09:23, November 29, 2012 (UTC)

With a hearty melee character, I didn't see much benefit in posessing this staff.  I am trying to keep my character 'honorable' for this playthrough, and chose to keep the priest alive/destroy the staff.  I also don't want any bounties to deal with. RedGrimes (talk) 14:17, January 15, 2013 (UTC)

It should also be noted that Eurandur level caps at 50, making him a useful recruit for the Blades. RedGrimes (talk) 17:22, January 24, 2013 (UTC)

Bug? Edit

Occasionally, Erandur just seems to stand around doing nothing instead of moving to the next objective. Happened once on the stairs before going to the library, which I was able to fix by running/walking against him until I had "moved" him all the way up the stairs, where he reverted to normal. The second time was after disabling the barrier, but I have yet to find a way to fix that... reloading my last save fixed it. 217.235.158.147 07:25, February 5, 2012 (UTC)

After following Erandur into the tempel and down to the blocked off era, he want me to follow him to the libery, but he stopps walking in the middle of the stairs. I fixed this by attacking him until he followed me and then i put away my sword as he was just outside the libery door, to stop the attack. I then gave him a shout of Unrelenting Force into the door, and then the door was unlocked, and the quest continued. This was on xbox360.

Hope this might help somebody else to finnish the quest!


Åsmund

Leaving the map and going back outside also helps with this bug. When you come back in and approach him, he should continue opening doors and barriers. —This unsigned comment is by 195.202.217.77 (talkcontribs) . Please sign your posts with ~~~~!

Vaermina's Torpor glitch? Edit

Ive gotten the Vaermina's Torpor before Erandur asked me to and it didnt glitch. This was on the XBox, anyone else have problems or is it just for the PC or Playstation? Should it be taken off the article? ----

Erandur Dissappear.

After I talked to Erandur and followed him, I went inside the temple, he dissappear, im in front of church with no hallways or any other door than the one I came in. Any help?

This also happened to me. He went in and I followed but he was nowhere to be found. I have returned multiple times and can not do anything inside. This was 20 or so levels ago and I don't want to restart yet. Is there a way to find the hidden door and open it without Erandur? What is tcl command and how do I send it? XBOX 360 96.18.242.116 21:24, October 19, 2012 (UTC)

Barrier not opening? Edit

I think this is different to the Erandur disappearing glitch described on the page... When I entered the temple Erandur was inside fine, but when he did his flaming thing to open the barrier it didn't open. He seemed to think it was open and started walking into it. After walking against the wall for a few seconds the game teleported him to the other side of the barrier, and the only way I could follow was by using the tcl command.

I reloaded the game I saved right before entering the temple, but the same thing happened again.


I have this issue as well, using a PC, 15jan14. Leaving and returning as well as reloading a old save does not help bypass this situation.

71.81.179.47 20:11, January 17, 2014 (UTC)J Ellison

Disabling magic barrierEdit

This was on the Xbox 360. I have drunk the Torpor. I have reached the barrier through the dream realm. I pull the chain to release the Miasma. Then when I take the soul gem, to release the barrier, it says that I have completed the objective and must speak to Erandur. The magical barrier has not disappeared. It is still there, I can not walk through it therefore I cannot speak to Erandur. I have tried reloading saves. I have tried going on ahead. Erandur appears in the staff's room. I complete the quest, but I cannot leave the temple due to the Barrier still being up.

Any idea on how to get past this? Ignore the quest entirely and wait for a future update? Or is their a way to fix this?

Door way glitch Edit

I was playing on xbox and when I drank the torpor and went into the memerories as I was going from one room to another a glitch made the doors and hallways connecting the rooms dissapear and instead all could see was blue mist. When I walked into it I fell and teleported to the beginning and couldnt finish. I then jumped over them and could make it through the memory but in the actual world it was the same and I was stuck for a long time. Finnally made it through to the end and those spaces made it easy to get out of the temple since i teleported instantly to the door.


Donovan Mclean

Odd bug Edit

I went through the temple and got the skull, but when I went back through the temple many of the priests were missing their robes. I was playing with conjuration spells. Has this happened elsewhere? (PS3) AmbieSushi 06:32, August 31, 2012 (UTC)

360 Unable to save game after coming back to reality from memory state. Any attempt to save or even the auto-save will cause the game to crash.24.17.97.220 09:10, November 17, 2012 (UTC)

PC Same bug as above. Once I take the gem to open the barrier I cannot save my game without being thrown out. 82.32.62.236 11:17, November 17, 2012 (UTC)

360 - Same bug as above, experienced on November 18, 2012. Any attempt to save after the memory causes the game to crash until I have finished the quest and left the building. Only way round was to complete the quest as quickly as possible and not open the menu until completed. Beximus (talk) 12:35, November 20, 2012 (UTC)


360- the newest patch/update (1.8 I believe) is what is causing the game to crash if you save after you have to release the Miasma. The game will still crash after getting the skull but I haven't checked if leaving after completing the quest and saving will crash or not.

360 - Same exact thing. I saved my game often - the crash occurs trying to save immediately after completing the mission. I guess I'll try continuing on for awhile after, but it doesn't seem hopeful :(  I've tried on both hard drive and cloud saves. No luck on either. (jan 29, 2013)

PC- I faced this bug too. Tried to save outside afterward, didn't work. Entered somewhere else, same thing. If you encounter this bug, I doubt you can count on completing it before a patch.


PS3 - After Releasing Miasma manuel save freezes game, but after quest complete manuel and auto save resume as normal.

PC - I have found a solution for this bug for PC version: open and load the game, then pres Alt+Tab to swich the game in backround, go to save directory, make a back-up of the save directory then delete all saved games (you created a back-up) and all .ini files from there. After you did this, Alt + Tab back to the game (game should be open in background the whole time) and complete the "Miasma" stage and afte that save and quick save options should work from now on

Strange bugEdit

So I went to the temple no problem and? Erandur did his normal talk , but then when we got inside the questarrow points to the wall,? Erandur is gone and i cant progress in the quest.

When you look at the map? Erandur is already at the end of the dungeon and I am stuck in the first room.

This was on XBOX360 can it be fixed? (i didn't save before entering and i tried to fix it by leaving and re-entering and by waiting, but nothing helps and because I was that stupid I got no save before entering, the last save was from 3 hours before :/ When you least expect it, I'll be there ~ sneakboy1 (talk) 18:08, November 23, 2012 (UTC)

(Alex)

Xbox 360:

Im doing the Waking Nightmare quest, and im up the the part of the quest of the "Dragonborn" opening the barrier door for the Preist of Dawnstar, after drinking the liquid". "Then after that point". Saving crashes the game. And saving works perfectly beforehand? I have almost no scraches on the disk even noticable, or that would cause the game to crash.?

I have not yet tryed going outside and saving to see if that fix's the problem, but seems to be more Glitch, then anything? If you have any ideas on how to fix the problem please tell me! :D

Nick

I have the same problem. It happened after i got the new upload. Every instance of saving crash the game. I even tried going outside and the auto-save had me stuck. I even tried with different characters thinking it could be a corrupted save file. Like Alex said, it happens right after you drink the Torpor.

 360  I have a problem saving after releasing the Miasma. Everytime I try it freezes up. and I have to power off and restart the system. Not sure if I'm the only one having this problem. LMK 99.144.72.238 18:13, November 26, 2012 (UTC)

Having the same problem as above on my 360 of not being able to auto-save after releasing the Miasma in the dreamworld.  I also tried a Quicksave with my Kinect voice command, and that also froze the entire system.  The only method I did not try was going into the actual Save menu.  Lee

Im also having trouble with the saving. I havent tried a whole lot, just tried the auto save, and a manual save a couple times. Still doesnt work. -Joe

I exited the building to see if that would work and I was able to get through the autosave as well as save normally after drinking the topar and breaking the barrier. I was having such a frustrating time with it. but since it worked at all, perhaps you just have to try it a couple times. 09:07, November 29, 2012 (UTC)

Updated with new information Edit

Torpur Glitch (360)  I have confirmed that the save crash can be worked around by exiting the temple following releasing the Measma.  Once you complete the dream sequence and take down the barrier, you should proceed outside of the temple before speaking with Erandur.  The resulting autosave will not crash the game, you will then be able to proceed back inside and have a save that will allow you to get staff for the daedra artifacts achievement and also allow you to go back and get Erandur as a follow if you so wish.  All further saves and autisaves will function normally within the temple. Subdoc725 (talk) 11:04, December 23, 2012 (UTC)subdoc725

I can confirm that the method posted above actually works for PC.  After re-entering the temple, all saving features worked flawlessly.  Thank you!

Walking Nightmare quest not being able to save or reload.                                                                                 I have incountered this problem/bug before on XBOX 360,when you try to save during this quest the game freezes,and when you try to reload it freezes.The best thing to do that i have done myself is to turn off all save and autosave features in the settings menu,and complete the quest without saving.Then when you have completed the quest make your way to the bar in dawnstar turn back on all your autosve features and create a new save file.I hope this helps anyone who's  having problems.

[PS3] - with patch 1.8 and Dragonborn DLC installed - I've been beatin my head against the wall to get around this bug - I tried the recommended "after taking down the barrier - go outside of the temple and save - then come back in and complete quest" - I want to report that it works. Thajduk (talk) 21:22, February 23, 2013 (UTC)

Going outside to save and then returning to the quest  fixed it for me too on the PS3 same as above AzuraKnight (talk) 08:23, April 5, 2013 (UTC)

Magical Barrier bug Edit

I have encountered a bug involving the magic barrier. After releasing the Miasma I teleport at the other side of the barrier as should but the soul gem powering the barrier is not present. Therefore leaving the barrier up and unable to leave or proceed with the quest.

Completely stuck after killing Veren and Thorek (PS3 and PC) Edit

I'm encountering a bug right after killing Veren and Thorek on PS3. 

It doesn't seem to matter how many times I reload and try again, when they're dead, Erandur just stands there and does nothing. No amount of pressing "X" will make him talk as the next objective states to do. The only thing he responds to is if I attack him and even that leads nowhere because once he gets to half of his life bar, he doesn't register any more damage. And he still won't render the skull inert. I'm becoming very frustrated... It may also bear mention that I never heard the words of Vaermina warning me that Erandur was going to betray me, as I've now read in the Wiki that is supposed to happen...

Any suggestions or work-arounds??

69.196.173.193 04:05, February 7, 2014 (UTC) Shakarr

The exact same thing is happening to me on the PC version...

82.229.171.156 21:33, May 9, 2014 (UTC)

I'm 99% sure Vaermina's warning only comes after Veren and Thorek are defeated. Only suggestion I have is to reload from a point before the Torpor is taken, and make sure to fully explore the entire dungeon that you can reach before drinking it. After releasing the miasma and shutting down the barrier, again make sure to thoroughly explore everything before you get to the inner sanctum. Maybe some area needs to be triggered before you start the battle. Cubears (talk) 15:30, May 10, 2014 (UTC)
Also, note this bug report: "Upon entering the library, if the book The Dreamstride is picked up before prompted to do so by Erandur, it may prevent him from prompting to look for it, making it impossible to continue with the quest." So make sure to not pick up either the book or the Torpor before he asks you to. Cubears (talk) 15:34, May 10, 2014 (UTC)

Eriandur teleporting bug? Edit

This bug report needs confirmation. Has anyone else seen it?

  • Also when entering the temple, he (Eriandur) may automatically teleport to the dreamstride book, meaning you cannot go through Vaermina's statue at the beginning of the temple
    • Reloading an autosave from just outside the temple may fix this

Cubears (talk) 15:31, April 20, 2014 (UTC)

      • I have a similar problem. When we enter the tower, we walk over to the tablet door, and Eri will cast his spell to open it, but it will not open. He'll then walk towards it, then after a few seconds, he'll teleport through it, leaving me stuck on the other side. I've tried going back saves, I've tried interrupting post-spell/pre walk, I've tried stepping out then stepping back in, but none of these have worked. 99.38.154.191 09:36, October 4, 2014 (UTC)

Bugs need confirmation: Slow/freezing game, can't folllow Erandur Edit

Can anyone confirm these bugs and the platform in which they occur?

  • After, or during the quest, the game will be extremely slow, freezing, and will freeze when opening the Item Inventory, equipping or looting items. There is no known way to fix this.. (Apart from reloading.)
  • Sometimes the Dragonborn cannot follow Erandur through the door to Nightcaller Temple.

Cubears (talk) 04:22, June 6, 2014 (UTC)

Around Wikia's network

Random Wiki