Wikia

Elder Scrolls

(DRAGONBORN) Mirrak ethereal bug.

  • Whenever I get his health down for the first time he won't come out of ethereal when he absorbs dragon soul... yet he will when he absorbs another (looks as if he requires 2 souls to become un-ethereal if thats a word.) I want to kill him get his armor,sword,etc and Im on xbox 360 so I cant use console commands... PLEASE HELP

      Loading editor
    • Sometimes he will get stuck in ethereal form if you deal too much damage. Kill the last dragon and let him absorb the last soul, then you should be able to get to the point where the end is near.

      If that didn't work then you have to revert back to a save before the battle.

        Loading editor
    • Thank you, I believe this is the cause... but I think I keep doing to much damage still... so should I switch to a different difficulty level or use different spells? Either that or the dragons aren't healing him up enough... (btw my weapon does 366 damage & Im using elemetal fury lvl 3...)

        Loading editor
    • If you want to avoid the whole bug then the best thing to do is kill all the dragons first. Kill Sahrotaar, then when he is dead, use Bend Will on one of the other dragons (Kruziikrel or Relonikiiv). Kill him when he lands, then tame and kill the last dragon. After all dragons are dead Miraak will be at the stage where he is supposed to die properly.

        Loading editor
    • Oh my god this worked! Thank you so much you are the best!!

        Loading editor
    • well, my miraak is ethereal because he didnt absorb the souls. can anybody help me fix the dragon souls  bug? :< FYI, i dont have unnoficial skyrim patch

        Loading editor
    • Dis solution is for the glitch when YOUR character absorbs the dragon soul instead of Miraak.

      Ok. After many many tryes and google searches i used the commands from the cosole SetsStage DLC2MQ06 500 to finish the quest then i used SetsStage DLC2MQ06 580 to bring the book up to be able to pick your perk and get home.

      BUT do it like dis !

      If you use dis commands while Miraak is ethereal will keep you stuck in combat ! And u cant use the book or anyting.

      USE the first command SetsStage DLC2MQ06 500 when he is not ethereal. Take a look if his still aggresive and coming for you, after dis command he will stop attacking. After you saw him stopping use the second command SetsStage DLC2MQ06 580.  At dis point you will have to hide till u get HIDDEN after that he will become neutral and you will be able to whatever u need to do. Dis is the only way that i managed to do dis. Hope it works 4 u2.

        Loading editor
    • This is caused by using fire damage, as it keeps hurting him a little bit after he becomes ethereal.  I'm pretty sure thats the problem since I tried with a fire sword, with incinerate, casting incinerate from the dragon, killing all dragons first etc... the only thing that worked is killing him with Icy Spears.  This is not a matter of how hard you hit him, but with what you hit him.  Well, thats what I noticed, could be wrong, but it makes sense, since it worked on the first try with the ice spell (works probably with electricity too.)

        Loading editor
    • 213.205.252.51
        Loading editor
Give Kudos to this message
You've given this message Kudos!
See who gave Kudos to this message

Around Wikia's network

Random Wiki