FANDOM


Heeeyyyooo, I'm back again with another round of tips! This time it'll be a different way to get a render of a character or item using the Creation Kit and Photoshop. Doing it this way won't get you as high-quality images as you can get using a real 3D program, but it takes a lot less time. So, without further ado, let's jump in.

Oh! Yeah...here's an example:

Aelathehuntress

If you're the sort that's too lazy to read, I've made a video tutorial JUST FOR YOU! You can find it here.

NOW we can start. First off, you'll need the Creation Kit. If you have to ask what the Creation Kit is or where to get it, you probably don't have what you need to use it anyway (you need a PC version of Skyrim, for starters). I'll skip over any introduction into the CK, for the sake of brevity.


Creation Kit 1
Open the CK and load Skyrim.esm (and Update.esm, if you want, it doesn't hurt to load both). Once everything is loaded and you've dismissed the multitude of errors that inevitably appear, navigate to the Actors node in the Object Window. Twirl it down, then select the Actor node. This will load a list of all the NPC's (actors) in the game.


Aela the huntress 3D program 1

Now select the actor that you want to render, I'll use Aela, right click and click "Preview", which will open up the...Preview Window. Uncheck the "On" checkbox under "Ground Plane", then find and select the "MT_Idle_Nervous.hkx" animation from the Havok Anim list (for some reason the MT_Idle.hkx animation won't load for me, maybe it will for you.) At this point your character should be standing there, relaxed, slowly swaying back and forth...idle (note that I hadn't selected the animation yet when I took the screenshot).

Line up your character how you want by using the left and middle mouse buttons and scroll to rotate, zoom and pan respectively. I found it useful to right click and lower (a lot) by Zoom and Pan speed values. I set my zoom speed to 0.02 and pan speed to 0.01. This will allow you to have greater control over the orientation of your character. You also want to make sure that the model is zoomed in as far as possible without going outside of the preview area, to get maximum quality and resolution. Now, with the preview window selected, hold the Alt key and hit the Print Screen key. This will take a screenshot of just the preview window (instead of your entire screen.


Aela the huntress 3D program 2

Now you want to open up Photoshop. I use Photoshop CS5, but these instructions are pretty basic and should work with previous versions. Create a new document (the width and height should already be set to that of the image in the clipboard) and hit ctrl+v (or Edit > Paste). Select a square around your actor making sure to not get any of the preview window bits in there, it should just be your actor on a gray background. Once you've got your selection, click Image > Crop. At this point you might be wondering how we're going to get rid of that gray background, well that's actually pretty easy. Set your active color to R 127, G 127, B 127 (exactly half gray), then create a new layer and fill it with that gray. Place the new layer below the screenshot layer, then set the screenshot layer's Transfer Mode to Difference (click the box in the layer panel that says "Normal" and in the dropdown select "Difference"). What you'll see is very ugly, but it's what we want. Duplicate your screenshot layer, set its transfer mode back to normal, and put it at the bottom of the layer list. Now right click the screenshot layer at the top (the Differenced one) and click Merge Down. Now hit ctrl+A and ctrl+C to select and copy everything, then click File > New and set the Color Mode to grayscale, then click OK (keep the first one open, we're coming back to it)


Aela the huntress 3D program 3

Now, in this new document, hit ctrl+V to paste in what you copied from the other one. Hit ctrl+L to bring up the Levels dialog and drag the right (white) handle all the way to the left, which will blow out the image, making it pure white. There might be a few holes (usually no more than a pixel or two each) that you'll need to fill in. You can see them in the screenshot to the left on the wrist and thigh. Simply set your color to white and draw those pixels in with the pencil tool (don't use the brush tool because the edges are feathered, you want to make sure you completely fill the area with white). Once you've filled in all the holes hit ctrl+A and ctrl+C again, to copy the image, then go back to your original document. You can delete the ugly-looking layer so that your only layer is the duplicate of the original screenshot. Now in the layers panel, click the "Channels" tab and create a new channel (the button is on the bottom of the panel, next to the trashcan icon). This will create a new, completely black Alpha channel. Simply hit Ctrl+V to paste in the black and white image you just made.


Aela the huntress 3D program 4

Now the rewarding part. Hold ctrl and click the preview thumbnail for the alpha channel, this should select the white parts of the image. Go back to the Layers tab, select your screenshot layer, and click the "Add Layer Mask" button (at the bottom of the layers panel, it looks like a dark square with a light circle inside it). This will turn the selection into a layer mask. Basically, with layer masks, anything white is opaque and anything black is transparent. Anything in between black and white is semi-transparent. At this point you should have a nice-looking cut out of your actor, with relatively little work needed to get it. You could leave it at that if you wanted to, but I couldn't help noticing those sharp, jagged edges. Luckily, it's pretty easy to clean that up and make it look better. Hold ctrl and click the layer mask (the black and white thumbnail on the layer), then click Selection > Modify > Feather. Type 1 into the box and click OK. Now hit ctrl+shift+i to invert the selection and hit the delete key once. This will erase a few pixels around the edge of the cut out, softening the edges out a bit and giving it a smoother look. What you're left with is a perfect cut out.


After a while doing this you'll start to get the hang of it and be able to knock out renders in a few minutes. Much better than manually cutting them out. I hope you've learned a little something, and feel free to ask questions, I'll do my best to answer them.


Note: After a while it might get a little annoying to have to manually crop the model to get rid of the preview window bits. To make this a little easier I use a simple program that I wrote that lets you take a screenshot of a specific portion of your screen and save it with a single keypress. You can download it here:

http://infectionist.com/extras/csharp/screenshot/Screenshot_1.4.0.zip

When you run the program you'll see the main control window and a box with a gray border and boxes in each corner, edge, and the middle. Click and drag these boxes to resize and move the box around, set it where you want to take a screenshot, then click the button. You can also hit F9, which does the same thing as clicking the button; F2 will automatically save the a screenshot to the last save location (default is the desktop); F3 copies the screenshot to the clipboard (which is especially handy for this). You can also double click any of the handles to expand it to the respective edge of your screen (double clicking the middle handle expands it to full screen).

Update: The screenshot program, despite not being updated in a year, is still a work in progress. I have a few updates planned for it, but I'd like to hear what you guys think of it if you use it. If you have a comments or suggestions, please let me know in the comments below.